Recently on Twitter Thomas Aylott (@SubtleGradient) recommended using `location` instead of `window.location`. I disagree. Yes, `location` is a global variable, but the problem is that it can be easily overwritten. A careless dev might use a global variable `location`. The same goes for `window.top`, `window.parent`, `window.self`, and `window.history`. Basically I say use `window.` for anything that could be a common variable name.